Honda and Acura Car Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
hey peeps, i'm new here. howz every1? neway i hope some1 can help. i am swappin in a d16z6 into an 88 crx si. problem i gots iz wen i start it up she revs straight to 4500 rpms! :( can any1 think of where i might have gone wrong?? thanks in advance
 

·
Registered
Joined
·
209 Posts
Could be ur Idle screw.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
k, i checked the throttle cable... was slightly tight. changed the map sensor and tps. now she idles at 2500-2700 when cold. when its warm the idle is inconsistent, it may idle at 800, sometimes as low as 600 then there are times when it will idle at 2500 when warm. thing is ... well its hard to explain, ...when i come out of gear and let it idle it will pick an idle and sit there...idle will not fluctuate (sp?). but the idle is, once again, inconsistent... BTW WHAT IS NORMAL IDLE ON A 5 SPEED D16Z6? thanks guys for the tips!!
 

·
Registered
Joined
·
25 Posts
normal idle on my 93 si was around 750 r you seeing n e trouble codes on your ecu thats the first thing you should check out it could be an engine coolant sesnor or your o2 sensors but check your ecu first if you dont know how reply to this reply
 

·
Registered
Joined
·
7 Posts
The idle on my '94 Civic EX D16Z is tuned to about 650.
 

·
Registered
Joined
·
1,170 Posts
check the IACV or ICV
 

·
Registered
Joined
·
152 Posts
Yeah I would say vaccum leak... When I installed my JRSC I had the same issue... I replaced all vaccum hoses with silicon ones, and my idle dropped, there was a few cracked lines and a few loose ones.

But make sure everything is connected to where is supposed to be.
 

·
Registered
Joined
·
10 Posts
i had the same prob.

first things is first. check for any vacuum leaks... then check if your coolant level is ok.. too low coolant will make your car idle hight to create pressure in the system.. then check your throttle cable to see if it is getting caught.... but this is what solved my cars problemm it may seem strange but it worked.... i changed the throttle cable rotor and the idle just dropped... i think it got fixed because the old throtle cable rotor used rubber bushings and they may have been getting stuck... i replaced it with the weapon r throttle rotor (also gives you quicker throttle response) and it fixed it... try it it was only $35 cdn...
 
1 - 16 of 16 Posts
Top