Honda and Acura Car Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi all I hope you can help. 91 Civic Hatch 1.5 I just checked my oil and found gas mixed in. I can smell gas but I just filled up so I thought that was it now I'm freaked. I have no codes. I still have lots of engine power am I looking at piston rings :wow . I will do a Compression test tomorrow. Last test that was done it was good. Any other sugestions...fuel pump, sensors, anything less expensive? Need help :confused :confused
 

·
Registered
Joined
·
20,101 Posts
Probly just because your rings are getting woreout. Or something is making it run rich. Is it cold where you live? Or have you been driving your car much without it getting good and warm? Have you started it and shut it off a few times in a row with out letting it warm up? Unless there is a ton of gas in your oil its not that big of deal. It just means your engine is getting some miles on it. I would suggest changing your oil a little more often because the gas will break down the oil and your engine bears don't like that.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Thanks for your advice. I am not sure what is going on I would think it would be a slow onset of gas in the oil not just suddenly. I also failed the emmission test the tester said I needed an O2 Sensor and Cat. Well I just rerplaced them 2 years ago?? I still have to do the compression test that will hopefully answer the engine question. Also did the head gasket a year ago not sure this car is a mystery nothing simple for sure. I am gonna switch out the O2 and fuel injector with a parts car I have see what happens.
 
1 - 4 of 4 Posts
Top