Honda and Acura Car Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
126 Posts
Discussion Starter #1
hey guys i have a 95 honda civic ex. well the problem started a few days ago i would be driving then it would shut off. its an auto btw. so i would pull over or just slip in in to neutral and start it up again. well now it wont stay on at all no problem starting up but right when i let off the ignition switch it shuts off. well interesting enough if i hold it half way after it starts the engine doesnt die. ive replaced the icm and the ignition switch and spark plugs. whats so diffrent from havin it idle and starting up? could it be the fuel filter? i just checked the injectors and no dirt physicaly on the out side. could it be the fuel pump? ahhh sooo many questions. thanks guys
 

·
Registered
Joined
·
20,271 Posts
stevenle said:
hey guys i have a 95 honda civic ex. well the problem started a few days ago i would be driving then it would shut off. its an auto btw. so i would pull over or just slip in in to neutral and start it up again. well now it wont stay on at all no problem starting up but right when i let off the ignition switch it shuts off. well interesting enough if i hold it half way after it starts the engine doesnt die. ive replaced the icm and the ignition switch and spark plugs. whats so diffrent from havin it idle and starting up? could it be the fuel filter? i just checked the injectors and no dirt physicaly on the out side. could it be the fuel pump? ahhh sooo many questions. thanks guys
so how do u keep the car from dying by holding the key on?but once u let go of key it shuts off?
 

·
Registered
Joined
·
126 Posts
Discussion Starter #3
yah right at the point where the starter is not engaged. replaced fuel filter and swapped pumps with another civic and still did the same thing.
 

·
Registered
Joined
·
20,271 Posts
stevenle said:
yah right at the point where the starter is not engaged. replaced fuel filter and swapped pumps with another civic and still did the same thing.
i still thinking is a ignition thing...because if u hold the key its ok.

try this unscrew the ignition from the left side and start it with a flat and see if it stays. the little clicker thing could be messed up so even when u just replaced the key and tumbler its doing the same
take the cover off and on the left side of the collumm ull see a round thingy with 2 screws take it out and u could start ur car with a flat or anything

see if u knoe wat im saying
 
1 - 4 of 4 Posts
Top