Honda and Acura Car Forums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
All,

Lately, I am having issues with my 99 integra. The check engine light (CEL) is ON. First time I have the dealer look at it. They did all kinds of pressure tests and found that there was no issue and I believe they turned off the CEL. Well, after driving for 150 miles the CEL came back on. The dealer looked at it again and found no issues.

Went to auto zone to find out codes: P1456. Changed the cap but there was no change. Recently, changed the radiator, cleaned throttle body/fuel injection system. Still the CEL is ON.

Any help on this issue....as to where to begin looking for the problem?

Thanks for your responses.
 

·
Registered
Joined
·
3,254 Posts
search for how to pull the code and then let us know what it says. or go to autozone and have them thell you what the p1456 means
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
P1456: Evaporative Emission Control System Leak Detected (Fuel Tank System)

Previously, someone had mentioned that I had a code for something associated with throttle body. I don't remember that code though. That's why I had the dealer clean the throttle body/fuel injection system.

I am not sure if changing the throttle body will make a difference.

search for how to pull the code and then let us know what it says. or go to autozone and have them thell you what the p1456 means
 

·
Registered
Joined
·
57 Posts
Maybe try ordering a new oem EECS from the factory...you're talking about the evap canister where the IM meets the TB right?
 

·
Registered
Joined
·
3,254 Posts
evporitive emission control canister. I wouldn't go changing parts out based on that kids suggestions. there is a number of probable causes that can cause that code. If you are really serious about troubleshooting it I can scan the Helms manual for you the troubleshooting guide for that code is 6 pages long and it has 13 probable causes.
 

·
Registered
Joined
·
1,328 Posts
All,

Lately, I am having issues with my 99 integra. The check engine light (CEL) is ON. First time I have the dealer look at it. They did all kinds of pressure tests and found that there was no issue and I believe they turned off the CEL. Well, after driving for 150 miles the CEL came back on. The dealer looked at it again and found no issues.

Went to auto zone to find out codes: P1456. Changed the cap but there was no change. Recently, changed the radiator, cleaned throttle body/fuel injection system. Still the CEL is ON.

Any help on this issue....as to where to begin looking for the problem?

Thanks for your responses.
as in cap do you mean fuel cap? because thats all it could be. if you did change that, then check for loose vacuum hoses and then the charcoal canister. it could be full of fuel and need replacing if valves went bad.
 

·
Registered
Joined
·
320 Posts
Just wondering..When I called my dealer for a service manual, they directed me to Helms..wasn't sure if it was the ACTUAL service manual.
 

·
Registered
Joined
·
274 Posts
did u check the evap lines running from ur tank to the black canister
 

·
Registered
Joined
·
12 Posts
I had this code before, granted it wasn't the same number and it was on an eclipse, but same description and oddly enough it was my gas cap.
 

·
Registered
Joined
·
57 Posts
evporitive emission control canister. I wouldn't go changing parts out based on that kids suggestions. there is a number of probable causes that can cause that code. If you are really serious about troubleshooting it I can scan the Helms manual for you the troubleshooting guide for that code is 6 pages long and it has 13 probable causes.
Sorry...thought this was a forum again my mistake...I'm only trying to help and I offered a SUGGESTION, exactly as you said and I said "Maybe" do this, as in check with your dealer/mechanic first...It's kinda hypocritical to shut down my SUGGESTION then offer your own...He doesn't HAVE to follow my suggestion (it was just an idea) and you don't have to shut down or flame EVERY one of my posts...plz leave me alone...With the exception of you so far I like this forum and it has been helpful to me.
 
1 - 17 of 17 Posts
Top