Honda and Acura Car Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hey there everyone. I have a problem after I swap my EK. It bogs and won't let my car rev past 2700 rpm. It would be so helpful if anyone know what's wrong with my car and help me out. And by the way I swapped it out to a B18b. Thanks.
 

·
Registered
Joined
·
475 Posts
you could have sensors on the intake switched that causes it to not rev over that a certain rpm sometimes. if you did any wire splicing or anything on the dizzy it could cause it to if some of the wires are touching...Or try and set time with your dizzy that might do it
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
2highpsi said:
you could have sensors on the intake switched that causes it to not rev over that a certain rpm sometimes. if you did any wire splicing or anything on the dizzy it could cause it to if some of the wires are touching...Or try and set time with your dizzy that might do it
thanks. i'll go and check the sensor to the intake. And yes i did some splicing to extend the injectors and the distributor.
 

·
Registered
Joined
·
475 Posts
it would be to your intake manifold sorry should have posted that instead of just saying intake...but yea it wont be in your injectors. i had the same prob with my h22 hatch. you might have bare wires touching each other or they arent making a connection at all
 

·
Registered
Joined
·
2,086 Posts
What do you mean you extended the distributor? to fit? please tell me you are not trying to use a d-series dizzy on a b-series... You need to make absolute certain that you swapped all the correct components that go with the b-series engine (i.e. distributor, ECU, harness, etc.), then if everything checks out, move on to diagnosing the ignition/timing system and go from there.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top