Honda and Acura Car Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
119 Posts
Discussion Starter · #1 ·
I've got a 1997 Honda Prelude with a Greddy Turbocharger kit installed as well as a custom built FMIC. The turbo has been on the car for about 2 years now and whats happening is that the car doesn't seem to hold boost at 7 psi anymore. Here is what's happening:

1. First to third Gear - Hits 7-8 psi
2. 4th gear - only hits 5 psi

I've checked my intercooler and charge pipes for boost leak and there are none so I'm kind of stumbled. Is there any reason for the car to hit 7-8 psi in the first three gears and then drop when there is more load (i.e. when I shift to 4th gear?)

Here are some of the responses I've heard just talking to other people:

1. Could be your spark plugs. You may be getting pre-ignition (Can someone explain further)

2. Could be an exhaust leak before the turbo (But if there was, I wouln't hit 7 psi in the first three gears right?)

3. Could be my wastegate (I can't see this as being a problem, usually wastegate problems yeild higher boost)

4. You removed the Catalytic converter. This may cause the lower boost at a higher load (again, I can't see this being the cause of the problem. Less exhaust restriction usually leads to higher boost. i.e. Getting a bigger downpipe would yeild higher boost.

Soooo, any smarty pants here that can help answer my question :)
 

·
Registered
Joined
·
119 Posts
Discussion Starter · #3 ·
Well, like I said, I have a hard time believing it's #3 because the wastegate works fine for gears 1-3. I have a Tanabe Super Medallion exhaust. The car was boosting fine with this exhaust before. Can you eplain further on why you think it could be problems #3 or #4?

-kl
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top