Honda and Acura Car Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
wassup,
I installed Ingall Camber kits on my 95' Honda Accord LX, but thye keep making sound...like squeaking... all the time, even driving on smooth road. So i had to get them lube like once every week, any suggestions??? (the mechanic that lube my car is very annoy now!! HELP FAST??!!)
 

·
Registered
Joined
·
292 Posts
I got the Sprint kit. Their pretty good. I modded my front wheel wells to get -.5 camber all around. I (like everyone else) get the squeeking sounds also. But for me its only if i go over major bumps. Over all im happy wit em.

Check out ImportStreetScenes in my sig for my pics
 

·
Registered
Joined
·
458 Posts
AccordRacing said:
I got the Sprint kit. Their pretty good. I modded my front wheel wells to get -.5 camber all around. I (like everyone else) get the squeeking sounds also. But for me its only if i go over major bumps. Over all im happy wit em.

Check out ImportStreetScenes in my sig for my pics

man... how did you manage to use the Sprint kit? i used to have the Sprint extreme camber kits for my 94 accord but then i can't use them properly, it was just out of no where to use it properly, so i moved on to the ingalls camber kits....

:confused:
 

·
Registered
Joined
·
66 Posts
have you got it lined up yet? mine squeaked when I first put it on but its stopped now. i noticed a huge diference when it was lined up and the days before that
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top