Honda and Acura Car Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
ok so i have a big problem. My car dies/chokes if i give it any gas under 2000 rpms. but if i rev my clutch over 2000 rpms to take off and keep the rpms above it, it drives okay.

its like that in every gear. it mis fires and bogs out under 2000rpms

what is the problem here? I tried cleaning my iacv

its also idling a little high around 1500rpms

the car is a 98 civic dx with a d16y7 the motor was from an automatic, and the car is a manual. Im getting no codes except for the IAT for which i am changing the plug for tomorrow
 

·
Registered
Joined
·
238 Posts
ok so i have a big problem. My car dies/chokes if i give it any gas under 2000 rpms. but if i rev my clutch over 2000 rpms to take off and keep the rpms above it, it drives okay.

its like that in every gear. it mis fires and bogs out under 2000rpms

what is the problem here? I tried cleaning my iacv

its also idling a little high around 1500rpms

the car is a 98 civic dx with a d16y7 the motor was from an automatic, and the car is a manual. Im getting no codes except for the IAT for which i am changing the plug for tomorrow
This is obviously a common problem in older Civics, a sputtering engine.
Problem is, there could be several things wrong.
1.) Coolant flow
2.) IACV
3.) IAT (change that plug and see what happens)
4.) TPS

The high idle could be caused by a sticky butterfly or flap inside the throttle or the idling valve needs to be adjusted. Maybe try taking off the intake boot and spray some intake/throttle cleaner in there around the flap and see if that helps at all. Also, spray some PB Blaster on the outside on the butterfly and rotate it back and forth. There could be some corrosion in there.

Also, check your timing and ignition system from the plugs to the coil. That's a possibility on the choking.
 

·
Premium Member
Joined
·
29,826 Posts
sputtering under load like that means you're running rich enough to choke the engine. did you check your plugs? common solution that's easy to fix and nobody ever checks them
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
Check this out. So my car had another y7 put in, because the old one blew up. Well anything under 2000 rpms it would bog/die ... as in if you gave it any gas under 2100 rpms it would pretty much die out. Well, I unplugged the Evap Purge Solenoid electric connector and now my car wont bog out under 2000 rpms, but i have a fluctuating idle. It sounds like ive got an insane lope at idle.

I tried swapped another evap purge solenoid and the same thing happened. Crazy idle. I dont think this is good for my car to be idling like that. so what could this be? I have tried alot of stuff. I went out and bought a timing gun, but need to find a writeup to figure out what im doing. Its the digital one from autozone where you can input the numbers.
 

·
Registered
Joined
·
238 Posts
Check this out. So my car had another y7 put in, because the old one blew up. Well anything under 2000 rpms it would bog/die ... as in if you gave it any gas under 2100 rpms it would pretty much die out. Well, I unplugged the Evap Purge Solenoid electric connector and now my car wont bog out under 2000 rpms, but i have a fluctuating idle. It sounds like ive got an insane lope at idle.

I tried swapped another evap purge solenoid and the same thing happened. Crazy idle. I dont think this is good for my car to be idling like that. so what could this be? I have tried alot of stuff. I went out and bought a timing gun, but need to find a writeup to figure out what im doing. Its the digital one from autozone where you can input the numbers.
Does the idle go up and down or does it spit and sputter?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
ok so i unplugged the evap purge solenoids electrical connection. now i can drive my car with no spits and sputters, but it idles up and down up and down up and down. cruising it seems it never even goes under 2000 rpms unless im at idle. its like cruise control lol.

the idle sounds as if i have a huge race cam.
 

·
Registered
Joined
·
238 Posts
ok so i unplugged the evap purge solenoids electrical connection. now i can drive my car with no spits and sputters, but it idles up and down up and down up and down. cruising it seems it never even goes under 2000 rpms unless im at idle. its like cruise control lol.

the idle sounds as if i have a huge race cam.
Check your EGR valve; it can cause funny idling when it goes bad and may trip other sensors in the process. It can also cause the engine to choke and die too since it works with the gas.
 

·
Registered
Joined
·
811 Posts
y7/y8s do not have EGR. Only the y5 does.

Do you have a vacuum leak? How does your brakes and power steering feel? If it seems harder than usually and it idles high, it could be a vacuum leak.
 

·
Registered
Joined
·
140 Posts
hmmm this is an interesting one...check the hose/line coming from the valve..and see if you smell gas, sounds like youre getting some "extra" fuel from somewhere.

its unlikely but possible for the evap system to be flooded with fuel...sometimes from people over filling their gas tanks and fuel gets into just about every part of the system. not a good thing at all my friend
 
1 - 12 of 12 Posts
Top