Honda and Acura Car Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Ok so im not getting any spark. I replaced the cap, rotor, and coil. Im looking to replace my ICM. My fuel pump isn't coming on except when I attach a jumper cable but I'm positive the fuel relay works because I swaped it in my moms car and it ran just fine. My friend suggested to me that because I've tried to start it so much that there's already pressure and that's why the pump isnt coming on, but in any case I replaced the fuel pump just in case but i ended up testing the old pump anyway and it still ran fine. I'm so stuck and I need my car running very soon.

I have a 1989 Honda Civic SiR with a swaped B18C5 head and B20B4 block, it's a OBD1 and has some new wiring from a 92-95 civic. It has a VTEC ECU but im not sure exactly what one it is.
 

·
Registered
Joined
·
1,052 Posts
Ok so im not getting any spark. I replaced the cap, rotor, and coil. Im looking to replace my ICM. My fuel pump isn't coming on except when I attach a jumper cable but I'm positive the fuel relay works because I swaped it in my moms car and it ran just fine. My friend suggested to me that because I've tried to start it so much that there's already pressure and that's why the pump isnt coming on, but in any case I replaced the fuel pump just in case but i ended up testing the old pump anyway and it still ran fine. I'm so stuck and I need my car running very soon.

I have a 1989 Honda Civic SiR with a swaped B18C5 head and B20B4 block, it's a OBD1 and has some new wiring from a 92-95 civic. It has a VTEC ECU but im not sure exactly what one it is.
If I understand your post correctly then the transistor in the ecu that turns on the pump is bad. Or the 5v power supply in the ecu is bad which canm cause the same problem. Try an ecu
 
1 - 5 of 5 Posts
Top