Honda and Acura Car Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
407 Posts
Discussion Starter #1
Ok, nowadays, the check engine light comes on randomly and when I accelerate, I cant rev past 4k! Whats wrong? and How do I fix it? I have a 02 Accord SE btw.
 

·
Registered
Joined
·
685 Posts
Y2A said:
Ok, nowadays, the check engine light comes on randomly and when I accelerate, I cant rev past 4k! Whats wrong? and How do I fix it? I have a 02 Accord SE btw.
Sounds like your car is in "limp" mode. I'd get that check engine light checked out with a scan tool. Maybe you have an O2 sensor out but I haven't heard of it causing your engine to go in "limp" mode. Go see your local dealer!
 

·
Registered
Joined
·
115 Posts
Hey, same car here. 02 Black Accord SE. Um... can't rev past 4k? Something wrong with ECU or like showgunz said, your O2 sensor? hasn't happened to me before so beats me. But my best guess, that check engine light coming on randomly sure might have something to do with the reason you can't rev that high. Any possibilities of something being wrong with the tranny? I mean sounds stupid but hey, if somethings small is wrong with it, wouldn't it limit you on how much you can rev?
 

·
Super Ban-Finger Mod
Joined
·
21,367 Posts
i've seen this happen a lot to the 6gen accords. you should still be under warranty, right? bring it in, they'll replace the ecu and have a look at everything for you. if the techs at your dealer cant' figure it out, have them call Diamond Bar Honda here in California. they just solved a similar problem....maybe something's defective in the ecu's and if they get enough complaints, they'll have another recall for it.
 

·
Registered
Joined
·
13,201 Posts
That happened to my buddy's car too, turned out that his ecu was fucked so he replaced the ecu and everything worked fine. But yeah if its still under warrenty check that out, or not replace the ecu.

Good luck.
 
1 - 6 of 6 Posts
Top