Honda and Acura Car Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
I have a 6th gen accord and after I had my headers installed, the check engine light comes and goes by itself. I did have to extend the o2 sensor from the front to the bottom of the header though. Does anyone know what the problem is? Could it be that the sensor is dirty? If so, should I try to clean it?
 

·
Super Ban-Finger Mod
Joined
·
21,367 Posts
you might have not wired it up properly which is causing it to short out.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
but it's not doing it frequently. It comes on for like a month and turns off. I drive for like another month, it comes back on. If I reset it, it goes away for about a month also. So I don't what the deal is.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #7
The shop said it was my 2nd o2 sensor which would be the one on the cat. Told me maybe it was sensing unburned gas. Would the placement change of the first o2 sensor make a difference if it was near the front (stock position) or down at the bottom (where it is now on the headers)? I don't really think the sensor is broken because I can drive for several hundred miles sometimes and when I push the car, then the cel comes on. Do I need to put my stock headers back on? I really don't want to.
 

·
Registered
Joined
·
1,254 Posts
I don't think you have to, unless you want to put your stock manifold back on. I would just say try to diagnose the problem with a shop. Even if you have taken it back there. I would pay $200 or so for a header and then have to put the stock manifold on. I really don't know how much you paid for yours, but i know its over $100+ or so. I'm just scared of getting headers cus i don't want my stock bolts to give and break. I mean my friend did it on his car, but then again, my car is older with a lot more miles on it.
 
1 - 8 of 8 Posts
Top