Honda and Acura Car Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
194 Posts
Discussion Starter #1
OK, i posted this in suspension also but nobody is responding
I have a 98 hb and yesterday we decided to put a set of coilovers on the car, well after we put one coilover on we pulled the car out of the garage and all i heard was a whump whump and like a loose sounding rattling coming from the suspension we had worked on. I KNOW everything is tight but what is making this sound and y??
 

·
Registered
Joined
·
11,248 Posts
I'm not trying to be funny, but you already know what the problem is. It is with the coilover that you just installed. Double check to make sure that you installed everything according to the instructions and that everything is torqued down according to spec.

You said that you just installed one. I would build the other, and double-triple check it... Then swap it with the one that is making the noise.

Are these true coilovers or coilover sleeves with shocks?

Also, just because it is tight doesn't mean that its right... hey that rhymes :) Anyways, I just did my suspension a week ago... Everything was tight and looked good, but it kept making a nasty thud whenever I hit a bump. Double checked and found that I had left off the brackets that go up against the wishbone on the shock body in the front. I had misplaced an instruction sheet that showed that I had to remove this bracket from the original shock and install it on the new one. Now she rides great.
 

·
Registered
Joined
·
194 Posts
Discussion Starter #3
The only sheet of directions that i was given is how to build it, it is a sleeve style (i know its prob junk) what i dont get is how it sounds like everything is wobbling and whumping. i am going to take some more looks now but i am thinking that i will have to put the stockers back till i can figure this one out.
 

·
Registered
Joined
·
1,393 Posts
whatsnaws? said:
The only sheet of directions that i was given is how to build it, it is a sleeve style (i know its prob junk) what i dont get is how it sounds like everything is wobbling and whumping. i am going to take some more looks now but i am thinking that i will have to put the stockers back till i can figure this one out.
they are sleeves right? how are the sleeves held in place? on my skunks they came with these rubber o-rings that u slide inbetween the coil sleeve and teh shock itself..so it wedges snug. my buddies weapon-r coils were held snug by these little allen key screws..they suck cause they just came loose and the sleeve started making the clunking noise when it hits the shock.
 

·
Registered
Joined
·
194 Posts
Discussion Starter #5
I have a silicon cover that slides over the shock and then inbetween the sleeve itself. i also have those o rings but the thing is, I have swapped the stock stuff back on and it is still making the same noise. I looked a lil bit harder and just noticed that the strut is not completely seated in the fork that is attached to the control arm (I think) any more help would be so appreciated
 
1 - 5 of 5 Posts
Top