Honda and Acura Car Forums banner
1 - 18 of 18 Posts

· Registered
Joined
·
782 Posts
Discussion Starter · #1 ·
Can anybody tell me why my cruise control light would be stuck on? I haven't used the cruise control on the car. Today when I took the car for a spin the cruise control light was on. I pressed the button on the dash that activates cruise control and nothing happened. The light stays on and cruise control doesn't work.....help.
 

· Registered
Joined
·
782 Posts
Discussion Starter · #5 ·
I looked at the electric diagram and I couldn't see a reason why it would light up but not work. Even the troubleshooting flowchart, which has like 35 reasons the cruise control won't work, doesn't have a starting point where the light is stuck on.

Do you think it could be that I have the control module hooked up improperly somehow? Is there a vacuum line that could be pinched or simply unhooked? I know nothing about the cruise control system and have never really used it on the Del Sol....but I can't bring myself to just take the bulb out of the gauge and forget about it. I HAVE to fix it...you know.
 

· Registered
Joined
·
146 Posts
There is a vacuum line that runs the servo motor which is how it maintains vehicle speed. Check the vacuum lines. I would think that if it were disconnected it would affect the idle. Also from what I have read it is saying there is a fuses and relay. I don't have cruise so I have no idea where these are located.
 

· Registered
Joined
·
782 Posts
Discussion Starter · #7 ·
There is a vacuum line that runs the servo motor which is how it maintains vehicle speed. Check the vacuum lines. I would think that if it were disconnected it would affect the idle. Also from what I have read it is saying there is a fuses and relay. I don't have cruise so I have no idea where these are located.
I looked at the cruise control servo actuator and it doesn't have any sort of vacuum line attached to it. During my installation of a new power steering belt and alternator belt I had to disconnect the servo actuator electrical plug. However, that is all that I did. I never touched anything under the dash where the cruise control box is.

So, is it possible that by detaching the servo motor I shorted out or damaged the actual cruise control box under the dash? Do all 1993 era Civics have a vacuum line attached to the cruise control? I

I think that something is wrong with the engine wiring harness / cruise control servo motor since that is all I touched.
HELP
 

· Registered
Joined
·
782 Posts
Discussion Starter · #10 ·
I have since checked almost everything in the cruise control system. Now the light stays off but the cruise control will not engage. When I press the switch to activate the cruise control the gauge the dash light stays off and the cruise doesn't work.

Any more ideas???
 

· Registered
Joined
·
782 Posts
Discussion Starter · #11 ·
Well after not getting anywhere on the forum with this I obtained a new cruise control module from a junked 1993 Del Sol Si with a manual transmission. I got it off of egay for $18. I will let you all know if the new module corrects my problem.
 

· Registered
Joined
·
4,086 Posts
dude, you take a punch, a well calibrated punch and a hammer. aim the punch at the light that stays on continuously and give it one good slam. make sure to calibrate the hammer and your elbow as well, because if you miss you could break something else
 

· Registered
Joined
·
782 Posts
Discussion Starter · #13 ·
dude, you take a punch, a well calibrated punch and a hammer. aim the punch at the light that stays on continuously and give it one good slam. make sure to calibrate the hammer and your elbow as well, because if you miss you could break something else
I could just buy some trained hamsters and have them sit on the gas pedal.
Of course they would have to be exactly the right weight.
I would need several different sizes to achieve the desired pedal level and speed.:ninja
Front, Back, Side-to-Side
Front, Front, Back, Back, Side-to-Side
 

· Registered
Joined
·
782 Posts
Discussion Starter · #15 ·
I replaced the cruise control computer and it didn't make any difference. Does anybody have any ideas about why my cruise control isn't working? The actuator works, the ECU works, the brake lights work, the cruise control buttons on the steering wheel work, the gas pedal works...etc...etc...etc.

Any help would be helpful.
 

· Registered
Joined
·
10,346 Posts
did you check teh switches mounted on the pedals? could be like a brake switch and have a plastic piece easily broken. even without using the cruising switch, it still pushes on it whenever you push down on the gas, brake, or clutch pedals


just a thought :dunno:
 
1 - 18 of 18 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top