Honda and Acura Car Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
67 Posts
Discussion Starter · #1 ·
I'm officially stumped. I installed a new relay and I still don't have working turn signals or hazard lights. Here's what I've tried/done.

All of the lights are on and working including brake lights, marker lights, and corner lamps. When I hit the turn signal switch I can hear the relay click but none of the lights flash. When the lights are on the Hazard switch (verified it's plugged in all of the way.) is lit, but nothing happens when the hazard switch is in the on position.

- New Flasher Relay.
- Reinstalled the factory front bulb holders and verified that I have good bulbs.
- Checked fuse 15. It is fine.

This problem just started recently. I put all of the plastics back on. Installed a new head unit and installed new turn signal housings.

Does any one have any recommendations. I have to pickup a multimeter to test continuity of the switches, etc.
 

·
Registered
Joined
·
421 Posts
It's honestly far too difficult to determine this without being there to examine for yourself you know?
Why did you replace the relay for one
for second, it's probably just not making a full connection
the biggest mistake i see with new head units is people unplugging the plug from the hazards to remove the dash then forgetting to plug them back in, therefore they get the relay sound but of course no actual blinkers or hazards
check this first, probably just a loose wire or something
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #3 ·
I'm just looking for ideas. I understand how hard it is to diagnose an issue without seeing it first hand, but thats not to say that people don't have ideas that I maybe missing.

I don't have to remove the Hazard switch in a Del Sol to change the radio. I did check the connection, tested, still didn't work. I unplugged and plugged the switch back in, and tested again. Still no flashing.

I replaced the Relay because I was hoping that was what the problem was. I knew the switch was plugged in. The fuses weren't blown, and the rest of the lights were working. So I went for the most obvious solution first. Unfortunately that was not the issue.
 

·
Registered
Joined
·
2 Posts
i have almost the same problem! i have a 94 honda civic dx coupe and my blinkers and hazards wont work either!! ive changed the relay twice and checked all the fuses! when i hit my blinkers or hazards the green arrow lights on the inside dont come on either! could it be a wiring problem?? i have aftermarket Halo headlights and im wondering if the people i bought the car from wired it wrong or maybe it has a short somewhere!! if u have solved this problem i would greatly appreciate it if u could help!! please email me at [email protected] and if u can solve it ill even sling u some money!!
 

·
Registered
Joined
·
1 Posts
Del SOl Turn Signal Problem

It is most likely the turn signal switch. Try opening the plastic cover on the steering wheel and with the switch in right or left mode tap around the switch area or see if you can clean the electrical connectors with some rubbing alcohol if it starts to work that is the issue.
 

·
Registered
Joined
·
1 Posts
I'm officially stumped. I installed a new relay and I still don't have working turn signals or hazard lights. Here's what I've tried/done.

All of the lights are on and working including brake lights, marker lights, and corner lamps. When I hit the turn signal switch I can hear the relay click but none of the lights flash. When the lights are on the Hazard switch (verified it's plugged in all of the way.) is lit, but nothing happens when the hazard switch is in the on position.

  • New Flasher Relay.
  • Reinstalled the factory front bulb holders and verified that I have good bulbs.
  • Checked fuse 15. It is fine.

This problem just started recently. I put all of the plastics back on. Installed a new head unit and installed new turn signal housings.

Does any one have any recommendations. I have to pickup a multimeter to test continuity of the switches, etc.

Did anyone ever find a resolution to this? Same issue, same situation - but not replacing the head unit. 1994 Civic Del Sol. Previous owner changed the headlights to halo style. Ambers come on, but flashers/blinkers do not work. Swapped the relay with no result. Looking for any resolution..??
 
1 - 6 of 6 Posts
Top