Honda and Acura Car Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
407 Posts
Discussion Starter #1
First off, I ordered some stuff for my .42/.48 T3.
I ordered a box of hose clamps for $10.99.... and what do I find in the box? ONE fucking hose clamp, wtf. I also ordered a 4-bolt exhaust flange, one of the ones that has the one bolt hole not in line with the others, and they send me some huge ass 3" 4-bolt cicular flange thing. Also the exhaust flange that blocks off the internal wastegate doesnt fit AT ALL and none of the 5 bolt holes are in the right place.
The only thing they got right was the godamn Deltagate flange. It also took them nearly 13 days to ship it and for $75 Im thinking what the fuck.
Definitely calling them today.

NOBODY BUY FROM TURBO-PERFORMANCE.
 

·
Registered
Joined
·
215 Posts
yeah, to bad you had a bad experience. I had great customer service from Bob, their main guy there. But of course, I actually went to the site to get my junk.
 

·
Registered
Joined
·
6,555 Posts
what kind of hose claps did you order? usually those things are pretty expensive especially those T claps ( i think they're called that) for intercooler pipes.
 

·
Registered
Joined
·
407 Posts
Discussion Starter #4
iLLeFFeKt CiViC said:
what kind of hose claps did you order? usually those things are pretty expensive especially those T claps ( i think they're called that) for intercooler pipes.
Nope, its one of the $1.50 ones with a screw you get at any auto place!
 

·
Registered
Joined
·
6,555 Posts
i see. yea you got screwed man. are you using those clamps to tighten the couplings for intercooler piping? how much boost are you running? i've had some problems blowing off intercooler pipes and now i use two clamps next to eachother to help it from blowing off. i wanted those T clamps but they are way too expensive.
 

·
Registered
Joined
·
407 Posts
Discussion Starter #6
I'll be starting at about 7psi since thats the spring the WG came with. It'll still be about another 2 months or so before I get the funds to buy the last things I need, which are intercooler pipes and downpipe bends, and intercooler (from johnny race car :p) so HOPEFULLY this intentional (common its obvious somebody intentionally put only one hose clamp in the box) messup will be resolved by then.
Also, nobody seems to have flanges for the turbo I have, so I guess its to the shop to make me up some, although im partial to laser cut steel :p

Thanks for the tip, if I have any problems with any hoses blowing off, i'll deff use two clamps. ;)
 

·
Registered
Joined
·
6,555 Posts
you problably wont have any problems blowing off pipes with anything less than 10psi.
i probably had that problem because all the clamps seemed rusted (old??) and running 15+psi.
 
1 - 7 of 7 Posts
Top