Honda and Acura Car Forums banner

1 - 20 of 34 Posts

·
Registered
Joined
·
3,921 Posts
Discussion Starter #1
Anyone have energy suspension motor mount inserts installed? Any difference?

Claims to provide easier shifting and reduced wheelhop on launch

~Peace
 

·
Registered
Joined
·
6,058 Posts
sweet, I've had some of these for ages just never put them in...lol...guess it's on my "to do list" haha.
 

·
Registered
Joined
·
117 Posts
The only downside to them is your car might feel like a vibrating chair until you get used to it, which could be good or bad. But MM inserts are one of the best mods you can put on a car for the money.
 

·
Registered
Joined
·
21,276 Posts
yeah i got the front one on my car....i'ma get the rear one installed this summer when i get my cams installed
 

·
Registered
Joined
·
3,921 Posts
Discussion Starter #7
Is that "vibrating chair" effect because any motor vibration is translated to the frame? I can get them on E-Bay for like... 30 Bucks.

I'm assuming I need an engine hoist to lift the motor a little bit... Do I need to disconnect anything when I install them? Or is it possible to just move the motor around a little bit and squeeze them in?

~Peace
 

·
Registered
Joined
·
21,276 Posts
IHIPrelude94 said:
Is that "vibrating chair" effect because any motor vibration is translated to the frame? I can get them on E-Bay for like... 30 Bucks.

I'm assuming I need an engine hoist to lift the motor a little bit... Do I need to disconnect anything when I install them? Or is it possible to just move the motor around a little bit and squeeze them in?

~Peace
the front takes 10 minutes to install. The rear....i was looking at it when i had my intake manifold off and i think i could do it with it off.
 

·
Registered
Joined
·
3,921 Posts
Discussion Starter #9
So with the IM off you could do it without an engine hoist? That's awesome because I was going to take my IM/TB off and clean them all out this spring... I'm sure there's a ton of crap built up in there... 82K miles of crap.

~Peace
 

·
Registered
Joined
·
8,403 Posts
pixs?
 

·
Registered
Joined
·
4,212 Posts
instaling all of them on all mounts will increase vibration, which i dont mind.

installation of the rear was kinda pain in the ass cause i didnt take off my IM. just make sure you put soap on it so it slips in easy. no you dont need a engine picker for this. but i suggest you to put a jack under the transmission or the oil pan depending which side you are doing for the side mounts.

oh also, i didnt see any performance gains, or anything, it just responds alot better though. instead of flexing then responds.
 

·
Registered
Joined
·
4,212 Posts
Matt said:
i dont really notice engine vibration at any rpm.....
idle, usually anything under 1,000 rpms. maybe 1200 and under, depends on the weather conditions.

plus when doing a real low rpm accelration, its more like a chatter but different. and it really shook up my dashboard soooo bad omg!! the rpm was for sure 1000 or under. I wished I had a video camera that time. I also had stage 3 clutch on so that could have made difference too.
 

·
Registered
Joined
·
21,276 Posts
Shibby H22A said:
did you install all of the 3 or 4 mounts?(forgot how many came in as kit) because if you did not, then it wont vibrate that bad.
there only two mounts that the ES inserts go in. What other mounts are you refering to?
 

·
Registered
Joined
·
6,058 Posts
98Vtec said:
there only two mounts that the ES inserts go in. What other mounts are you refering to?
I was wondering the same thing, I was sure there was only front and back :confused
 
1 - 20 of 34 Posts
Top