Honda and Acura Car Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hi, hope you guys can help. My son (Chase) has a 90 crx si with a zc swap. We bought it with the swap but are continuing to upgrage. Our last experiment is causing some problems I think. We wrapped his hedman headers with thermo tec header insulation to get some of the heat out of the engine compartment. The heat was reduced dramatically, BUT now the car does not rev as freely from 3500 to 4200 rpm. Thinking that we may be flowing better and needing more fuel we swapped the SI ECU for a integra ECU (pg6 to pg7). This didn't help. The car pulls as strong as ever until the engine warms up and then the problem resurfaces.

Does anyone have a suggestion or similar experience? Yes I know we could try removing the header wrap but a) its a painful process and b) we would like to keep it if possible.

Thanks in advance
 

·
Registered
Joined
·
8,403 Posts
ok, does this car have a full tune up, all filters etc etc?
 

·
Registered
Joined
·
8,403 Posts
so then ALL the filters have been changed? oil air, fuel, etc etc , and u have new spark plugs?
 

·
Registered
Joined
·
8,403 Posts
u have no check engine lite?
 

·
Registered
Joined
·
173 Posts
could be spark advance system.
might wanna check that. is it computer controlled advance, or (more likely) cintrifical or vacuum advance system?

also, check the timing belt. they should have checked that when you had the tune up, but it might be safe to just check it. even if the belt was good, they might not have done an actual check of the timing position.

how many miles on the engine?
 

·
Registered
Joined
·
1,174 Posts
I would check the timing as well... Do you have any vacuum leaks?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #10
Thanks for the suggestions. While checking the timing, we discovered a timing belt that was about to go. It had jumped a couple of teeth also. Thats being repaired today. I will let you know if that solved the problem.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #11
Update, found a broken transmission casing while reparing the timing belt. Should be finished with that by Friday nite. Am installing lightweight flywheel and new clutch while i have it apart. I think the timing solved the problem but can't really drive it to tell yet.
 

·
Registered
Joined
·
5,438 Posts
Chase's DAD said:
Update, found a broken transmission casing while reparing the timing belt. Should be finished with that by Friday nite. Am installing lightweight flywheel and new clutch while i have it apart. I think the timing solved the problem but can't really drive it to tell yet.


somebody is a bit ambitious....

the timing belt sounds like it was the problem, hope you have fun with the car!!
 
1 - 12 of 12 Posts
Top