Honda and Acura Car Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
yes i have a 2000 honda prelude with turbo installed and my fuel cut off is around 6500 rpm's and won't let me rev any higher, if any one can help me it will be appreciated thanks
mike
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
nah i don't have stock injectors only 330cc but only on 7psi it ran good for bout a year then just started to cut off
 

·
Registered
Joined
·
7 Posts
Discussion Starter #7
i even got the emanage system by greddy also i just don't have any idea, all the vacume lines are in none are leakin but iono if it could be any of my sensors
 

·
Registered
Joined
·
7,299 Posts
trbh22 said:
i even got the emanage system by greddy also i just don't have any idea, all the vacume lines are in none are leakin but iono if it could be any of my sensors
well if your usen greddy emange... then more the likey it wouldnt matter to much about the sensors.hummm. you do a compression test? Stock bottom end?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #9
yup everything is stock for now,head, bottom end stock, but it going into the shop to get fully built ya know
 

·
Registered
Joined
·
7,299 Posts
trbh22 said:
nah everything is stock i don't think it that you think it could be the idle speed sensor
hummm. i dont know to much about that sensor.

everything stock? fuel pump stock? i hope not. if so that where your problem is. boostin on a stock fuel system..is a big no no. 18g is a pretty big turbo too.
 

·
Registered
Joined
·
7,299 Posts
hell yeah. its not suplly aough fuel for the turbo. could be leaning out, wich is cutting the fuel. im surprised your boosting :bash get a fuel pump. you could be maxing out your fuel injectors. i dont know. thats the problem i would say.
 
1 - 14 of 14 Posts
Top