Honda and Acura Car Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
110 Posts
Discussion Starter #1
Well I've searched and searched and checked everything I can pretty much check. Just wondering if anyone has any ideas..
I have a 92 Civic and a JDM GSR motor swap. Everything seems to be in working order. The motor will start if I shoot a shot of brake clean in the throttle body and run until that burns up but idles fast. I pulled the injectors out and they are squirting out fuel. Tried a brand new main relay, new fuel pump, have fuel pressure set at around 40psi. We tried messing around with the fuel pressure but still doesn't make a difference. Does anyone have any idea's? It seems as if the injectors just aren't squirting enough gas....

I have a brand new set of 550cc injectors I tried just for the hell of it and the car would start up and idle for about 40 seconds by itself then die.... Wouldn't start great but it would start and idle..

Any ideas or comments would be appreciated.

Thanks,
Chris
 

·
Premium Member
Joined
·
29,826 Posts
why the hell do you have multiple threads about the same topic. seriously?.... :bash
 

·
Super Nazi Mod
Joined
·
5,806 Posts
well multiple threads aside. I had the same thing on my saturn and ever since then I make sure people test it just in case cause I wasted a week on something so simple. is your exhaust clogged? between the header and the midpipe take it apart and start it up to see if its clogged. if it starts up and runs your exhaust is clogged.
 
1 - 3 of 3 Posts
Top