Honda and Acura Car Forums banner
1 - 4 of 4 Posts

· Banned
Joined
·
1,529 Posts
Discussion Starter · #1 ·
My battery light keeps coming on and I got a new battery. it worked fine until the batter died again. My alternater had been making a screaching sound before when I would start the car and then the belt went to hell. But now I put a new belt on there and the battery light still comes on. I would think that it's my alternator except that when I rev the engine past 3k the light goes off. Please help!
 

· Banned
Joined
·
1,529 Posts
Discussion Starter · #3 ·
crx4luke said:
I think it could be the alternator. When you're reving int past 3 k the alternator is going to be at full charge. You might want to get the alternator tested.
yeah I went to pull the alt and found that the bottom mounting bolt was missing... turns out I forgot to put it on when I did the engine swap (OMG!!:eek: ) and that was probably the cause of the alt bearing failure. so I replaced the alt and everythig's OK

thanks for looking Luke
 

· Registered
Joined
·
163 Posts
CRX4Luke, dude it's your alternator, I just went through that problem, and the reason why your belt was making that noise is cause you didn't have it adjusted tight enough. Tip make sure you remove both battery cables from the battery before changing the alternator. you could blow your starter like I did.......
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top