Honda and Acura Car Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter · #1 ·
I have a '90 Accord LX with a swapped in H22. Everything is working great on it except when I turn the wheel the slightest bit to the right it clunks like crazy. I replaced both CV axles and the intermediate shaft, I also had both tie rod ends replaced, an alignment done and I replaced the sway bar links...

Could it be the wheel bearing, maybe a bent wheel hub?? I need help on this, please share all ideas...

Thanks
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #3 ·
That's what I thought but the diff turns very smoothly when the axle is not connected to the wheel assembly but when connected to the wheel it's very unsmooth makes the whole engine move just when I spin the wheel by hand
 

·
Registered
Joined
·
211 Posts
i think i have the same problem.. only when turning
i think the tire rod that i installed got problem

i am not sure tho........ recent half shaft that shop installed torn.. aswell
camber is pretty bad too.. left positive and right negative...

wish had a new car from beginning.........
all end up the same...
 

·
Registered
Joined
·
1,639 Posts
thats weird, i have a pretty hard clunk when im at a steady throttle and step on the brakes, or if im accelerating hard. it seems like if the car shifts back it clunks, and if the car shifts from back to forward, it clunks...in the front end somewhere.
 

·
Super Ban-Finger Mod
Joined
·
21,366 Posts
johnlude85 said:
thats weird, i have a pretty hard clunk when im at a steady throttle and step on the brakes, or if im accelerating hard. it seems like if the car shifts back it clunks, and if the car shifts from back to forward, it clunks...in the front end somewhere.
bad motor mount. front or rear....my guess is most likely the rear.
 
1 - 8 of 8 Posts
Top