Honda and Acura Car Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
4,212 Posts
Discussion Starter · #1 ·
Sorry if pics are large, and some are blurry for some reason...

Pics of exhaust valves


the head, notice how white the exhaust valves are!:eek:


number 2 exhaust valve


Piston no.3, notice the stratches from old broken rings, its not that too bad, it was the same as it was when i first removed my head a couple years ago, but only a couple more new stratches thats it.


Ummm, the block... with carbons toasted and roasted on the piston head.


Im just gettting the exhaust valves reworked on and the head vaccum tested, steam cleaned, hopefully it will be done tomorrow or wednesday. Then ill put it back together and hopefully done by thursday.
 

·
Registered
Joined
·
4,212 Posts
Discussion Starter · #4 ·
samd77 said:
WOW... look at that carbon!

Are you getting any other head work done? triple cut valves? port & polish? Regrinding all the valves?
No, its a long story, but to make it short, i have been running very lean. Notice the valves are white, and piston head shows denoation. Reason why im running lean, i ran a jet for my nitrous fuel line that was for with higher pressure fuel, but since i switched to stock fpr, the fuel pressure is lower, so i ran lean even on 50 shot, so it all messed up my exhaust valves, and cause unburnt fuel to exit and cause the o2 sensor to think im running rich. So o2 sensor tells the ecu im running too rich, and ecu reduces the injector pluse rates, causing me to go too lean even off the bottle..

So im just getting the exhaust valves redone just for now, and get the head vaccum tested, cleaned up. Thats it, no performance gains, just gain the power i lost at high ends.

I'm going to remove my nitrous kit for now, since i suspect a faulty fuel solenoid, its a really old kit.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top