Honda and Acura Car Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
hey peoples, my freakin car putters under 4500, but when i mash it, the car doesnt seem to hesitate as much. I just changed my igniter, cap and rotor last year at the cost of about $300. What the hell could be the problem now...i need some mad help thanx..btw..its a 96 LS...and to add a little more...the guy at the shop says it sounds like a blown motor at idle...but i'm all motor never used NOS or boosted so I dont know what the problem is...one other problem they said is that I could have a bent valve...aight
 

·
Registered
Joined
·
2,575 Posts
spoonteg21 said:
hey peoples, my freakin car putters under 4500, but when i mash it, the car doesnt seem to hesitate as much. I just changed my igniter, cap and rotor last year at the cost of about $300. What the hell could be the problem now...i need some mad help thanx..btw..its a 96 LS...and to add a little more...the guy at the shop says it sounds like a blown motor at idle...but i'm all motor never used NOS or boosted so I dont know what the problem is...one other problem they said is that I could have a bent valve...aight
Its not blown...did you change your fuel filter as well?

What mods do you have done to it?

EDIT: Whats the condition of the spark plugs and wires?
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top