Honda and Acura Car Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
207 Posts
Discussion Starter #1
Yesterday on my way to work.. I stepped on it against a truck and one of those commercial trucks.. all of a sudden my car really kicked in wit some high ass rpm... after I passed the two trucks my instrumental panel went out.. I thought it wuz my fuse but the back lights and the instrumentel panel uses the same fuse but the back lights wuz ok... Can it possibly b the bulb itself or did I really mess somthing up...?
 

·
Registered
Joined
·
207 Posts
Discussion Starter #3
Naw can't b the fuse.. like I said before the backup lights and the instrumental panel uses the same fuse.. and my backup lights wuz ok.. shiet I hate takin my car to the fuggin dealer for dis kinda shiet.. Still got that SRS light on too.. what a lemon.. feel like kickin HONDA's ass or somthing
 

·
Registered
Joined
·
207 Posts
Discussion Starter #7
Well the dash is out dats 1 the rear lights are out the signal lights are out.. the clock is working and the radio button lights are out.. What works Headlamps work.. backup lights work, when u turn on the signal lamp both sides work.. all needles are still working.. warning lights currently working such as SRS, Check ENgine light and so on.. The remote key access works but it doesn't make the sound it use too and the two front signal lights doesn't blink like it use too.. And the sound u get when u have ur lights on and key out isn't working... Well dat's all I know so far.. Hope u guys have some helpful info.. thanx peepZ:)
 

·
Registered
Joined
·
685 Posts
Do you have problems starting your car up? Are you using any underdrive pulleys, perhaps AEM? Check your alternator. Those Delphi alternators are notorious for not lasting a long time, even when the car is in stock form.

It sounds like you got a serious problem in the electrical system. Some components that work and some don't. Perhaps you made a short in the circuit. Or even fried a wiring harness.

It also sounds like your relays may be out. But multiple ones. All of this happened at one time, right? This is some freaky stuff, man. To tell you the truth, I never heard of this happeneing, at least not with so many lights going out at once.

Check your battery for the voltage level too. That can cause a few things to not work well.
 

·
Registered
Joined
·
207 Posts
Discussion Starter #10
Batterys ok and I dont' have any new pulleys, never change the alternator though.. but the car still runs... been driving it for the past 2 days.. Maybe somthing is friend but it's a relay shouldn't it find another way to cross?? thanx bro for ur info
 

·
Registered
Joined
·
685 Posts
I really don't know how a relay work. But I figure there are basically a complicated switch. And when things are not connected to be powered, you get dead electronics. I can be completely wrong here, but I do believe relays are important and needed to power up electronics.

Do you have an aftermarket alarm system? Do yourself a favor and still get your charging system checked at Pep Boys or AutoZone. They should be able to do it for free. Or, a very, very remote possibility is that all of those bulbs just blew at one time. That's another thing you can look at.
 
1 - 11 of 11 Posts
Top