Honda and Acura Car Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
hey everyone, when i start my car and let it idle, it usually revs to about 2000 for a while (i think thats normal) then it drops to normal idle speed (about 1250) then it drops a little bit to about 700 then up to about 1250 then drops then back up then drops then back up then, well you get the idea, and its not just at startup, when i park the car after driving for a while it still does it, also when im at stoplights. basically does this occasionally, and when it does, it does it when i come to a stop over the course of the whole trip (if you understand that). also, i looked at my computer box, and the LED is giving me a code 12. this has something to do with the EGR valve right? should i just replace it?
 

·
Registered
Joined
·
1,639 Posts
for the idle problem, all you have to do is search the forums. now, im supposed to provide you with a link if i tell you to search (site rules) but i do not have time to search for myself, for you. i can tell you its either the idle air controller or the fast idle valve. the rest you can find on your own im sure.

as for your code 12, yes it DOES have something to do with the egr "system", but not necessarily the EGR valve itself. that, youre going to have to troubble shoot and diagnose, or have a tech do it. pm me ill see what i can do for ya. i might have something thatll help. ;)
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
thanks for replying. i totally forgot about the search function. so whaddya got for me?
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top