Honda and Acura Car Forums banner
1 - 5 of 5 Posts

· Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
Whats Up? I was driving home from work the other day and they made me detour a bit, so I came across and unfinished road, it wasnt too bad...just a little bumpy and some holes here and there but I avoid them....So, I got off that road and came across a paved one when all of a sudden it sounded like my car was a train...I mean when I went to take off it sounded like a very loud, annoying shrill sound coming from my front left tire...If anyone has ever heard a train stop on tracks then you will know what I mean...
It definitely sounded like metal on metal somewhere. So, I got out and check to see what the hell was happening when I could not find any obvious things wrong...no flat tire, nothing hanging from underneath the car that was dragging or anything.
The car still rode and drove find, no bumpyness or anything. I didnt even notice any trouble with braking...It almost seem like it only did it under acceleration or something.
But it definitely scared me pretty bad. Also it didnt do it in reverse at all...only in the forward gears...5spd....

Any help would greatly be appreciated and it also quit somehow and doesnt do it for now...But I would like to get it fixed b/c its embarrassing....Thanks!
 

· Registered
Joined
·
7 Posts
I'd say you just have a little rock stuck in your caliper. Same thing happened to me a while back.
 

· Registered
Joined
·
46 Posts
Or it might be your wheel is loose , check all your lugnuts , it happened to me one time , same story , and my wheel camne loose bc the lugnuts werent tight and i hit rocky gravel and then went on the road and it sounded like a train ... hope it gets fixed

- BomexTEG
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top