Honda and Acura Car Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2,752 Posts
Discussion Starter #1
After I put coilover springs on my car and prothane urethane motor mount inserts in my 2000 si, it makes this weird creaking sound when i take of at any speed, it didnt do it at first but after a few weeks, it started. is it the shocks or something with the motor mounts?
 

·
Registered
Joined
·
2,752 Posts
Discussion Starter #3
thanks alot man, ive been worried about it alot but it makes alot of sense now. also, will the front camber kit from a 96 civic fit my 2000 si?
 

·
Registered
Joined
·
2,073 Posts
2000redCIVICsi said:
After I put coilover springs on my car and prothane urethane motor mount inserts in my 2000 si, it makes this weird creaking sound when i take of at any speed, it didnt do it at first but after a few weeks, it started. is it the shocks or something with the motor mounts?
u said u put the motor mount inserts.. did u lubricate them cuz if it is dry and not has been lubricate with some certain grease such as silicon or watever, then it'll make a squeaky sound cuz two motor mount inserts between the motor mount tend to rub against each other and causen squeaky noise.
 

·
Registered
Joined
·
2,752 Posts
Discussion Starter #5
thanks guys, you all get rep, after investigating what you guys said i found that after using silicone spray on them it shut right up and i noiced on warmer days it doenst do it, thanks again.
 

·
Registered
Joined
·
63 Posts
I am having the same problem with my eibach springs. Making the funny noise when I take off. I thought it was my exhaust rubbing against the car. My springs r also riding real low in the back. When I bought the car in Nov. it had the eibachs and a huge sound system in the car. It has been cold so I have not had time to take out the sound system. It is to big for the car. So my car is in the shop as we speak. I will post what they told me was making the noise if it helps u.
 
1 - 8 of 8 Posts
Top