Honda and Acura Car Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
145 Posts
Discussion Starter #1
what's up guys.

i just got a spoon front strut tower bar for my car and while installing it i noticed that the brackets didn't sit so flush over the shocks. It's not horrible but it's also not what expected from a brand like spoon. oh well, maybe i'm trippin'. i bolted it down anyway and it looks great, it's just that the brackets don't sit like i thought they would. do you guys think that maybe i was sent a bar for a DC2 by mistake? is there a noticeable difference?

thanks in adavance.
 

·
Registered
Joined
·
1,388 Posts
the strut bar should fit both the 2 door models and the 4 dr models. do u have pics of the strut bar installed in the engine bay?
 

·
Registered
Joined
·
145 Posts
Discussion Starter #4
i juts installed it on wed and i haven't had time to take pics yet. on a side note, i have a coolant leak now. the concerns for my strut bar just became second priority.

:(
 

·
Registered
Joined
·
1,388 Posts
thanks 1 O. G teg!:)

-----

B18Chillin,
does the strut bar look like this:




if it's still not flush, try to take it off again. loosen up the bolts and re-install again. if it still doesn't suit u, just tighten it as tight as u can to discourage any play with the bar.

p.s.
is ur coolant leaking from the radiator or from the reservoir?
 

·
Registered
Joined
·
145 Posts
Discussion Starter #6
i think i'm cool with the bar. obviously, i'm a bit of a perfectionist and would like nothing more than for that bar to fit flush. but i couldn't figure it out and it's bolted down pretty tight, seems like it's going to work fine.

about my radiator:

i'm sorry to say i'm one of those bolt-on guys who doesn't know too much about basic mechanics and maintenance..

the coolant looks like it leaking from the belt side of the engine. I can't really see anything from the top and nothing on the bottom because there is that plastic guard under the front end of the engine bay. i can't tell if it's leaking where it looks like it's leaking from or if the coolant is just running down along the plastic piece to the closest point of exit. sorry, i'm not the best at explaining stuff like this.

i don't think (i'm hoping) it's not my radiator, seeing as how it's just a little over a year and a half old. i keep telling myself it's just a hose.
 
1 - 6 of 6 Posts
Top