Honda and Acura Car Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
Alright my car has been idling up and down 1200 to 2200 up and down up and down..well i was told to clean the iacv and check the coolant lines..well i did all that and it did not work my car is still idling crazy like that...i clean the throttle body..the only thing i haven't done that was suggested i do is to check the fast air idle valve..which i don't know where that is exactly if anyone could help me out that would be great becuz i do not want to spend tons of money taking it to someone that is going to charge me out the ass for something i could probably take care of myself....any tips would be great thanks
 

·
Young&Dangerous
Joined
·
10,160 Posts
Do you have an afterMarket intake...?
Check to see if you have the hose connected to your valve cover!
What is your make/model?
 

·
Registered
Joined
·
19 Posts
Discussion Starter #3
yes i have an iceman short ram intake and i the hose is connected to my valve cover my ..car is 99 prelude sh
 

·
Young&Dangerous
Joined
·
10,160 Posts
Check to see if you have a leek in that hoes.
When I installed my intake I was idling that high also.

Did you lose a cap! In you TB?
Check that!

Is your cable tight! Try using sum kind of grease too grease the thing that holes the cable! (Sorry don’t know what it called)
 

·
Registered
Joined
·
21,276 Posts
the fast idle is located directly under the throttle body. i am thinking you have a bad IACV tho. Unplug your iacv and see what happens. If nothing different happens then you prolly need a new IACV unit.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #7
what is the eacv??? and when i unplug the iacv there is a drop in idle speed all together so i am not sure if i need an entirely new iacv..but if i do how much could i get one for...i wish there was another 5th gen luder that i knew so i could take there iacv off and put it on mine to see if that is the problem but unfortunately i know no one...but thanks for the help so far..i'm still thinking of possible problems..i don't believe i have any vacuum leaks becuz i have checked for those also......
 

·
Registered
Joined
·
21,276 Posts
hooride99 said:
what is the eacv??? and when i unplug the iacv there is a drop in idle speed all together so i am not sure if i need an entirely new iacv..but if i do how much could i get one for...i wish there was another 5th gen luder that i knew so i could take there iacv off and put it on mine to see if that is the problem but unfortunately i know no one...but thanks for the help so far..i'm still thinking of possible problems..i don't believe i have any vacuum leaks becuz i have checked for those also......
the iacv is one unit, if its messed up, you gotta replace the whole thing. www.hondaautomotiveparts.com has them for 180. I gotta buy mine sometime. Mine is unplugged.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #9
if i was to unplug mine would that prevent it from idling like that..and if so when that induce any other damage to the engine while running it without the iacv plug attached?
 
1 - 9 of 9 Posts
Top