Honda and Acura Car Forums banner
1 - 4 of 4 Posts

· Registered
Joined
·
4,811 Posts
Discussion Starter · #1 ·
I bought this 93' prelude throtle body from a friend. He had it put

on his 94' intergra. Anyways we install it and now when my car is

idling my RPMs fluctuate from 1000 to 1500 RPM. I have a

Tannabe Racing Medalion so it's pretty loud and annoying.

I have a 97' integra. I asked my friend about the fluctuation and

he said that it would do when he first installed it but he said that

after a while it went away. What the deal with this? Is it good

for my engine the way it revs up and down for no reason.

:ken: :ryu: :sonic: :gundam1:
 

· Registered
Joined
·
192 Posts
Not exactly sure but..

First i wanna ask- whats thi mm on that throttle body? WHy did you purchase it- and for how much?
The idling problem could relate to map sensor not reading the right amount of vacume at idle. Did you reset your ECU? <--- try that if you already havent. Also, make sure there is not one spec of dust or dirt or contaminants on the throdle body or on the butterfly itself. It is a direct fit, correct?
 

· Registered
Joined
·
1,012 Posts
check your throttle cable too ... when you put the new TB on, you might have tightened the cable too much. just make sure it doesn't have the TB open a lil bit even when completely off the gas ... if u need instructions ... Club si. com has them under performance or something like that. The instructions are for a 99-00 si, but worked on my 96 ex ... and shuold work for your integra too.
Good luck
 

· Registered
Joined
·
4,811 Posts
Discussion Starter · #4 ·
My friend was selling his car and bought it off of him for 70 bucks

I don't know what size it is. (got it to go faster)

My friend had it on his 94 integra

I have reset my ECU about 4 times now.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top