Honda and Acura Car Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
i have a rough problem that iv been trying for 2 years to fix now.
I have a 91 Acura Integra RS B18A1, non Vtech.
The main problem- Randomly dies like its not getting any gas...pedal down RPM's drop lower.
1. it IS getting gas to the injectors
2. iv changed out the fuel pump&sock, as well as cleaned out the gas tank.
ran good for 2 miles then same thing.
3. it IS in time, and the battery IS being charged.
4. the only other thing i can think of is "Overheating"....but temp gague says otherwise(with a new synsor)...stays in the middle.
5. when this problem randomly occurs the oil light comes on and a few sec's later the check engine light...
6. it will start fine after letting it set for a few, but as it runs the problems slowly creaps up and you can tell whats about to happen.
anyone have any ideas?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
someone hit me with this idea...there may be a grading or "screen" of some sort in the fuel rail....and it could be getting clogged or just restricted enough to mess with the fuel, air ratio thus causing it to wana die fairly quick whenever the debris is pulled across that grading...
This whole problem started when it ran out of gas for the first time**
 

·
Registered
Joined
·
5 Posts
Have you tried changing the oil and cleaning the fuel injectors? And if it is as you say, I can imagine it won't always get completely blocked and only let partial or incorrect amounts of fuel through causing your air fuel ratio to be off and making your ride jumpy or lagged?
 
1 - 7 of 7 Posts
Top