Honda and Acura Car Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
163 Posts
Discussion Starter #1
Well I have a question: I just bought a Rockford Forgate (Punch) 2 channel 200 watts. I'm just using one channel and hooked it up to a 10" Bazooka. At idle, I noticed that the rpm goes down when there is bass and at night the lights dim a little bit. Do I need a bigger battery? New alternator? Or is this normal? Does it affect performance do to the power drawn from the battery? Thanx
 

·
Registered
Joined
·
5,487 Posts
At the rate you are going your alternator is gonna fry pretty soon. Get a Capacitor, and that will eliminate the sub from sucking the power in surges. I'd get a cap anyways, even if I was pushin a 50 watt amp, but thats just me because i am paranoid like that.
 

·
Registered
Joined
·
150 Posts
i got my rex5 years ago and have ran 2 amps at one time then just back to one 100-480watts. ihave the same alternator that honda put in there,and its still in there.sure my lights dim a little at idle when the bass hits ,but i find its more often someone hooked something up wrong that gives you trouble.
 

·
Registered
Joined
·
150 Posts
oh, mine does not affect performance,i yanked (disconnected) the power wire to see- no difference. but i suppose if its rigged it might.---just get someone who knows what theyre doing to look at it
 

·
Registered
Joined
·
175 Posts
I'm pushing 360 watt rms through my PPI amp and I havent noticed anything like you describe. Check your connections and that you dont have any shorts or anything. I dont have a cap or anything special to drive the amp.
 

·
Registered
Joined
·
2,113 Posts
your amp is not going to do that unless you have a really weak electrical system. how big is your amplifier wire? i recommend at least 6 gauge when powering any sub. also, might want to check up on the battery. might be too old. upgrade your 3 main electrical wire if you have to (battery, battery negative to ground, and engine to ground)
 

·
Banned
Joined
·
846 Posts
yea, it sounds like you have a weak battery. Get a new battery, if you can, an optima yellow or red top.

As for Caps (capacitor), i wouldnt reccomend one. People are mixed up with how caps really help. If you dont have the power to feed just the amp, how are you going to charge the cap and keep the amp running? Caps were mainly designed to HELP out in an already strong electrical system, not as a cure for dimming lights. If you are getting Dimming with only 1 amp, it sounds like you have a weak battery.
 

·
Registered
Joined
·
492 Posts
I would also suggest getting an Optima Yellow top Battery... not red :D
I believe you could also get a line driver so you dont have to push your amp as hard... correct me if I'm wrong though.
 

·
Registered
Joined
·
1,389 Posts
i used to have 2 eclipse aluminum 12s pushed by a orion hcca 900 and a 500.4 orion xtr pushing my 6.5s and with out the capasitor the lights would dim alot...with 1 farad cap it was ok but still not great i would try and get a good battery like optima and a 1 farad cap if u do anything more than a lil 200 watt amp....but u may need a new alternator alot of strain
 

·
Registered
Joined
·
163 Posts
Discussion Starter #12
Thanx for the replies. I connected the stereo system, and I did it right, I've been connecting stereo's since I was 13. The battery has always give problems, so I might as well change it. Also I used Rockford Fosgate amp kit, so I think the wires are well siuted for my amp.
 
1 - 12 of 12 Posts
Top