Honda and Acura Car Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
200 Posts
Discussion Starter · #1 ·
Well, it's been a long time since i've been here....I think june was the last time. I've had my 94 Accord in the shop for about 3 months (was on vacation in Florida) It's ok though....I had some good bonding time with ma supraTT. Anyway, I had some framework done and replaced pretty much everything on the front drivers side except for the brakes, shocks and springs.

Everything was fine the first day...but then when i started the car the second day, it made some kind of wooshing noice, kind of like fluid flowing. Whenever i turn the wheel, it makes really loud squeaking, screeching noises...but there are some points when i do turn the wheel it all stops. Sometimes i have to hold it at those places just so i don't get annoyed at stoplights.

I thought that it was probably the power steering because I did notice some light brown fluid on the ground in my garage floor.

I used some power steering additives and it fixed the leak but hardly helped with the noise.

So what do you guys think it is? Power steering pump? I really need to fix this fast because there are a lot of young kids interested in the car.....willing to pay A LOT of money for it
 

·
Registered
Joined
·
813 Posts
you have a bad power steering pump. mine is doing that right now, well, earlier. then it stopped. i opened my hood only to find power steering fluid all over the place. :( :mad:
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top