Honda and Acura Car Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
alright i did the h22 swap on my 4th generation SI and now it just completely runs weird. my gas peddle is extreamly hard and i think i screwed up on 1 or 2 of the vacum hoses and shiet. my engine now idles at about 1,500 RPM. ok so my questions are does anyone have a diagram of the placements of all vacum lines or at lease can point me in the right directions? and is there anyone with the know how on why my gas peddle is almost rock solid, with an idle at 1,500 RPM...this really sucks for gas milage :p i drop 1 gas bars just by going to the store once or twice. i just want this thing running right...kind makes me miss the old h23
 

·
Registered
Joined
·
2,705 Posts
SI-Vtec said:
my gas peddle is extreamly hard and i think i screwed up on 1 or 2 of the vacum hoses and shiet. my engine now idles at about 1,500 RPM.
Check the battery ground for your car. I had to change my battery ground cause the ground was almost completly rotten. My car was using the throttle cable as a ground causing the cable to heat up and the plastic covering to melt on it and making the cable stiff and got really hard to press. Kinda felt like it was crunchy.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #5 ·
ok i'll search up the vaccum hose diagram. but i did find out why the pedal was so hard. when i did the swap there was a connector on the throttle body that i didn't know where it connected too so i stoled the throttle body off the other H22 that looked exactly like the h23 throttle body. (i had 2 sets of h22s, company made a mistake and i ended up with one free :D ) but when i switch the throttle body the little attachment that held the cable to the throttle body was longer then the original so after switching it back to the shorter one the pedal's now fine. it still idles funny though, which is making me worry.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #8 ·
thanks..that was helpful..car's running fine now..:D now if only i had vtec hooked in :mad
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top