Honda and Acura Car Forums banner
1 - 6 of 6 Posts

· Registered
Joined
·
45 Posts
Discussion Starter · #1 ·
Ok i got a sunpro 2 5/8" tach, if i mounted it on my dash i got them 4 wires running around till i feed it through firewall and it wont look clean, i really want to mount it on the left pillar, but how do i get the wires behind the plastic? do i have to drill a hole? and tips on how to do it or how you did yours would be greatly appreciated. THANKS!
 

· Registered
Joined
·
45 Posts
Discussion Starter · #4 ·
i mounted on the pillar to the left of the steering wheel, i took off the rubber and the plastic on the pillar, drilled a smalled hole and then put a screw through it and mounted it, you cant see any wires and it looks great. if u need to know more, PM me
 

· Registered
Joined
·
1,142 Posts
so you pretty much mounted it yourself onto the pillar rather than using pillar gauge pods or anything... that's cool. . . think you could take a pic? i'd love to see how it came out.. so like... inside the pillar you can just send the wires straight through to the firewall?
 

· Registered
Joined
·
45 Posts
Discussion Starter · #6 ·
no what i did was, i ran the wires down behind the pillar, and it came out down below by my fuse box, then i just ran it through a plug in the firewall..i didnt use any pods just bolted it on. looks good i will try to get a pic
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top