Honda and Acura Car Forums banner
1 - 10 of 10 Posts

· Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
yea so i just bought a pair of xenon bulbs and i really liked how they looked , and a few days later i of em went out. im pissed, i didnt touch em when i put them in or anything. do these bulbs just suck?
 

· Registered
Joined
·
33 Posts
i have had them in for over a year never blew one from Hiper Industries but i have blown apc 1157's in a week
 

· Registered
Joined
·
8 Posts
I had some Japanese xenon bulbs before, but burnt out in 7 months. Which is not that bad though, because I've heard lots people complained their bulb burnt out within 3 months.
I'm having PIAA now. And they provide 1 year warranty too. (At least the local distrebutor will provide that)
 

· Registered
Joined
·
62 Posts
Del La Sol said:
over the past year i've ordered like 10 pairs of xenon bulbs for people, i "installed" all of them and did it perfect, several pairs including my own blew with in a week... they were all Hiper Industries
Really? My Hiper Industries bulbs are still working perfectly, even after a year's worth of use. They were, however, 9005 and 9006 for the Accord. I haven't done anything for the del Sol yet. Were you using standard wattage or high wattage bulbs? I have the high wattage H4 bulbs for the del Sol, and I'm sorta afraid to install them.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top